Shaideru

All things iOS & Swift

Could not locate configuration file: ‘GoogleService-Info.plist’

As we know that firebase keeps updating their API due to Apple’s Swift 4 coming out, and found this issue today while implementing Firebase API, here’s a quick fix for you.

When you are connecting your xcode project file after installing your pod, and you already added,
FirebaseApp.configure() inside didFinishLaunchingWihtOptions function, and imported Google-Service-info.plist, select the GoogleService-info.plist and select your projects name under Target Membership(right panel).

Build and run your project, voila!

Leave A Comment

Your email address will not be published.